Monday, May 28, 2007

Pidgin for Dapper

Hi everybody!

The popular Linux instant messaging program GAIM has changed its name to Pidgin with the introduction of version 2.0. I had been looking for a Pidgin .deb package for Ubuntu Dapper and couldn't find one. So instead of waiting around for one to appear I built one today from source. I have installed it and it seems to be working fine and it has 'adopted' the settings and accounts from the previous GAIM installation.

I would like to share this package with anyone who might need it. But first let me warn you that I am not an expert at building packages. I do not know what dependencies are required by Pidgin but I would suppose they would be the same as for the GAIM 2.0 betas. This package will not tell apt-get to resolve dependencies so I strongly suggest you install the GAIM 2.0 beta packages and handle the dependencies that way.

Use this package at your own risk!

Pidgin 2.0.1-1 for Ubuntu Dapper [Link 1]
Pidgin 2.0.1-1 for Ubuntu Dapper [Link 2]

P.S. Please let me know if there are any problems with the download links.

[EDIT] Installing the following packages should resolve any problems with dependencies. Copy and paste this command in a Terminal window... and run it, of course.
sudo apt-get install libgtk2.0-dev libxml2-dev gettext libnss-dev libnspr-dev libgtkspell-dev

7 comments:

Anonymous said...

i've downloaded and installed it, but i can't find it in the applications menu

Shane said...

Sorry I'm not an expert at building packages. I put this one up as I hadn't found a deb package for pidgin.

Have you tried restarting X? ie Ctrl+Alt+Backspace... does it work by typing pidgin in Terminal? If it works fine but still doesn't appear in the menu you can add it manually using alacarte.

If this bothers you, you could always uninstall it using synaptic... which is the main reason I made the .deb... so I can remove it easily if I mess things up d:-)

Roberto said...

wow thanks Shane

I've just downloaded and installed, as happened to the other friend the link didn't apear in my menu, but after an X restart Crtl+Alt+Backspace everything apears to be working just fine, the icon is there and my acounts were automatically loaded.

I'm working with Ubuntu 6.06 Dapper and my previous Gaim was 1.5 (I didn't unistalled it), so I think there is nothing to worry about the dependencies.

Thanks again, and I'll tell you if something goes wrong.

Ro

Shane said...

glad to hear all is well :-)

Sayan ঋজু Chakrabarti said...

I think you might also need libpurple (the new face for libgaim!) as a dependency. Just my $0.2 ;-)

Shane said...

is libpurple in the repositories? i have moved on to feisty... and it isnt in the feisty repos... so i dont have libpurple but pidgin 2.0.2 is working fine... one compiled by me...

maybe i'm missing something and i don't know.

Aizudin said...

two thumbs up bro!